x86_64-linux-gnu-gcc: error: unrecognized command line option ‘-fstack-protector-strong’ 

Depois de atualizar o Debian sempre quebra o meu ambiente, e estava tentando instalar o pycrypto aqui e sempre aparecia o seguinte erro:


x86_64-linux-gnu-gcc: error: unrecognized command line option ‘-fstack-protector-strong’

error: command 'x86_64-linux-gnu-gcc' failed with exit status 1

fui verificar o que era esse ‘-fstack-protector-strong’ e ele faz parte do gcc 4.9[0], e minha solução foi atualizar o gcc, mas achei esse comando bem legal:


sudo apt-get install build-essential

Bom é isso, preciso melhorar muito meus posts hehehe mas até a próxima.

[0] http://www.outflux.net/blog/archives/2014/01/27/fstack-protector-strong/

See you space cowboy…